[RELEASE] One-Click UnBrick updated 10july11

Rating

No votes yet

301 posts / 0 new
Last post
AdamOutler's picture
Offline
Joined: 03/25/2012 - 06:44

odd.... Can you get your USB Device ID?

IE..
04e8:6601

04e8 is samsung, the device 6601 is what we are looking for. It should be somewhere in your device manager... I don't know how to get that exactly on windows, but on Linux it's "lsusb" or "lsusb -v"


Rhiannon224's picture
Offline
Joined: 04/22/2012 - 00:24

The device ID is wrong, that must be the problem. In device manager here is what I found USB\VID_04E8&PID_681C&REV_0400 and USB\VID_04E8&PID_681C

AdamOutler's picture
Offline
Joined: 03/25/2012 - 06:44
Quote:
Originally Posted by Rhiannon224
View Post
The device ID is wrong, that must be the problem. In device manager here is what I found USB\VID_04E8&PID_681C&REV_0400 and USB\VID_04E8&PID_681C

that does not look right.... that's wierd. Is that your captivate?

to get to the same USBID I'm looking at...

1. right click on "My Computer"
2. click manage
3. select Device Manager from the right panel
4. Double click the device.. (in my case "gadget serial")
5. select details tab
6. select "Hardware Ids" drop-down.

Code:
USB\VID_04E8&PID_6601&REV_021;
USB\VID_04E8&PID_6601

Have you seen the Zadig file yet?

AdamOutler's picture
Offline
Joined: 03/25/2012 - 06:44

I've attached zadig.exe to this post. Let me know how that works for you.

1. Launch it with your phone connected and in download mode
2. select Options> List all devices
3. Select USB device (gadget serial)... maybe something else?
4. Install driver

I will work on a "windows problem resolution center" if this works.

edit: oops.. had to compress the file. Reuploading now.

http://forum.xda-developers.com/atta...1&d=1309991416

Rhiannon224's picture
Offline
Joined: 04/22/2012 - 00:24
Quote:
Originally Posted by AdamOutler
View Post
that does not look right.... that's wierd. Is that your captivate?

to get to the same USBID I'm looking at...

1. right click on "My Computer"
2. click manage
3. select Device Manager from the right panel
4. Double click the device.. (in my case "gadget serial")
5. select details tab
6. select "Hardware Ids" drop-down.

Code:
USB\VID_04E8&PID_6601&REV_021;
USB\VID_04E8&PID_6601

Have you seen the Zadig file yet?

Yes I have seen the Zadig file, I have to choose the product code and vendor id to get the drivers.

I went to Device Manager and those were the numbers when I double clicked on Samsung USB Android Component Device, that's how my phone is showing in the device manager. I know they aren't correct. I am thinking it's becaue of the custom ROM being based on source that isn't Captivate source. My IMEI is correct however, the PCode is not, it says it's SGH-I8972KAXEU. I am not sure what source Cezar is using in Continuum 6.1 but I suspect it's the culprit. I may have to restore my nv_data to get things back in order. The link you posted isn't working.
This is all very weird.


Rhiannon224's picture
Offline
Joined: 04/22/2012 - 00:24

Zadig doesn't see it in download mode. It's not a Windows problem, it's my device.

AdamOutler's picture
Offline
Joined: 03/25/2012 - 06:44

Ok. Ill try to figure out what's up with that. It may be a device which is not yet supported by heimdall. Ill branch the code and see if I can submit a patch. Continuum you say? Ill look at that one.

Tweak4fun's picture
Offline
Joined: 12/11/2012 - 19:49

Adam...Confirmed working on Mint 11 64 bit. My phone is a captivate running Continuum 6.1 with the Talon kernel.

Great work!

jetpuck73's picture
Offline
Joined: 10/03/2012 - 23:57

Nice work!!!


golfslicer's picture
Offline
Joined: 02/25/2012 - 05:18

Installed and followed instructions and it did get my phone out of a soft brick on windows 7 x64, however, now odin won't work and the heimdal frontend does not detect the phone. What do I need to do to flash a kernel with this installed. I reinstalled the drivers for odin and it detected but got a bad flash for the first time. This is after I installed the drivers for heimdal. Like I say the unbrick work, but now I need to flash and neither one will work.

Ok, I got odin to work again, by reinstalling drivers through kies. It doesn't appear that both drivers will work at the same time.